Project Details Degraded Performance
Incident Report for Bridgit
Resolved
This incident has been resolved.
Posted Aug 31, 2023 - 15:13 EDT
Update
We're aware of an issue affecting the performance of the Project Details view related to project budgets. We are actively investigating multiple resolutions. The impact will vary based on many factors within Bench accounts.
Posted Aug 31, 2023 - 13:20 EDT
Investigating
We have received reports that the performance of Project Details is slow. We are currently investigating.
Posted Aug 31, 2023 - 13:12 EDT
This incident affected: Bridgit Bench (Web App).