May 28 - Bench EU - Account Data Not Loading

Incident Report for Bridgit

Resolved

Our Team has identified and resolved the issue. Thank you for your patience.
Posted May 28, 2025 - 13:01 EDT

Investigating

We are currently investigating this issue.
Posted May 28, 2025 - 12:59 EDT
This incident affected: Bridgit Bench EU (Web App).